Subject: [jira] Created: (COCOON-2300) jboss-5.1.0.GA vfszip protocol in CharsetFactory

From: "Douglas Hurbon (JIRA)" <[email-masked]>
Date: Wed, 1 Sep 2010 17:00:54 -0400 (EDT)

jboss-5.1.0.GA vfszip protocol in CharsetFactory
------------------------------------------------

                 Key: COCOON-2300
                 URL: https://issues.apache.org/jira/browse/COCOON-2300
             Project: Cocoon
          Issue Type: Bug
          Components: Blocks: Serializers
    Affects Versions: 2.1.11
            Reporter: Douglas Hurbon
             Fix For: 2.1.12-dev (Current SVN)

Cocoon fails to initialize on Jboss 5.1 due to the new vfszip protocol it uses for class loading.  CharsetFactory expects either jar:/ or file:/

Parsing the vfszip protocol in CharsetFactory solves the problem.

--
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

---

From: "Douglas Hurbon (JIRA)" <[email-masked]>
Date: Wed, 1 Sep 2010 17:02:54 -0400 (EDT)

[ https://issues.apache.org/jira/browse/COCOON-2300?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ]

Douglas Hurbon updated COCOON-2300:
-----------------------------------

    Attachment: CharsetFactory.patch

Patch for the CharsetFactory running on Jboss 5.1.

>         Attachments: CharsetFactory.patch
>
>